Touchscreen Lost

From Unofficial Tesla Tech
Jump to navigation Jump to search

So you've upgraded your eMMC chip and put the CID back in your MCU, screwed everything together and put it in the car. But the touchscreen doesn't work! Well that's no good.

Chances are very good that when you opened the MCU, the shortest cable got pulled and strained its connector on the MCU mainboard. That is the touchscreen cable. If it were 4" longer you could open the MCU like a clamshell.

Touchscr Connector1.jpg

But as it is you've opened the unit a bit too wide and caused slight cracks at the strain points.

In the process this bends back the two ground contacts, which are high in the connector, so they no longer make with the cable. In the above picture I've already fixed my problem as the ground contacts are proud of the plastic. But you may find that yours are not visible.

Don't try to replace that connector using an infrared soldering station; unless you do that every day there is a low probability that you'll succeed given the fine pitch of those data contacts. The solution is to get a fine X-acto knife and gently insert it into the slots, pushing the ground contacts back out, each in their turn. They don't have much spring (the reason they'd bent in the first place) and are easy to bend back into position.

But you still have the problem of the cracked connector. It doesn't move much but why leave it to chance?

Use hot glue to overlap those cracks and reinforce the whole side. If you get glue on the slots for the black keeper, cut that out before it hardens.

Touchscr Connector2.jpg

If you like you can use an ohmmeter to test continuity of all contacts like I did, but it's not necessary to test more than grounds as data contacts are down low and safe.

Put everything back together and you're in business.

Carl A. Cook